Memisahkan Traffic Local dan International Menggunakan BGP

Walaupun dengan menggunakan teknik nice.rsc sudah dapat membantu dalam memisahkan traffic local dan international tetapi akan lebih baik jika pemisahan dilakukan secara langsung menggunakan BGP.

Pada artikel ini saya coba memberikan gambaran bagaimana caranya memisahkan traffic local dan international menggunakan BGP di mikrotik, untuk ilusrasi dapat dilihat pada gambar dibawah ini

Image

Dari gambar diatas mikrotik router AS65002 melakukan BGP peering dengan Cisco ber AS24521, mengapa harus dengan cisco? setidaknya fitur di cisco lebih lengkap dan memadai atau mungkin saya baru bisa memisahkan traffic local dan international lewat cisco Smile

masalahnya utk memisahkan traffic local dan international selain outgoing juga incomingnya harus terpisah

Berikut adalah contoh script di cisco AS24521

interface FastEthernet1/1
description Interface Indonesia from IDC
ip address 218.100.27.215 255.255.255.128
ip policy route-map from-nice-to-users
duplex auto
speed auto

router bgp 24521
–cut–

neighbor 4.4.4.2 remote-as 65002
neighbor 4.4.4.2 description User RtRwNet
neighbor 4.4.4.2 next-hop-self
neighbor 4.4.4.2 soft-reconfiguration inbound
neighbor 4.4.4.2 route-map DU-NICE-ONLY-EXPORT out
neighbor 218.100.27.129 remote-as 7717
neighbor 218.100.27.129 description NICE OpenIXP
neighbor 218.100.27.129 next-hop-self
neighbor 218.100.27.129 version 4
neighbor 218.100.27.129 soft-reconfiguration inbound
neighbor 218.100.27.129 route-map AS7717-EXPORT out
no auto-summary

ip as-path access-list 7 permit ^7717
ip as-path access-list 7 deny .*

access-list 110 permit ip host 5.5.5.0 host 255.255.255.0
access-list 110 deny ip any any

access-list 140 remark traffic dari luar ke User RtRwNet
access-list 140 permit ip any 5.5.5.0 0.0.0.7

route-map AS7717-EXPORT permit 10
match ip address 110
!

route-map DU-NICE-ONLY-EXPORT permit 10
match as-path 7
!
route-map from-nice-to-users permit 10
description User RtRwNet
match ip address 140
set ip next-hop 4.4.4.2
!

Sedangkan di Mikrotik scriptnya sbb:

/ routing bgp instance
set default name=”default” as=65002 router-id=0.0.0.0 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=no redistribute-other-bgp=no out-filter=”” \
client-to-client-reflection=yes ignore-as-path-len=no comment=”” \
disabled=no

/ routing bgp peer
add name=”nice-openixp” instance=default remote-address=4.4.4.1 \
remote-as=24521 tcp-md5-key=”” nexthop-choice=default multihop=no \
route-reflect=no hold-time=3m ttl=1 in-filter=”” out-filter=”” comment=”” \
disabled=no

Di Mikrotik yang menjalankan BGP tidak usah mengadvertise networknya karena yang diperlukan hanyalah daftar prefix network local dari AS7717

Hasil dari peering tersebut adalah sbb:

Di router cisco:

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

4.4.4.2 4 65002 4344 10266 134143 0 0 08:15:02 0
218.100.27.129 4 7717 132927 110928 134143 0 0 11w0d 2822

Di router mikrotik

B – blackhole, U – unreachable, P – prohibit
# DST-ADDRESS PREF-SRC G GATEWAY DISTANCE INTERFACE
0 A S 0.0.0.0/0 r 2.2.2.1 1 eth1
2 ADb 58.65.240.0/24 r 4.4.4.1 20 tunnel
3 ADb 58.65.241.0/24 r 4.4.4.1 20 tunnel
4 ADb 58.65.242.0/24 r 4.4.4.1 20 tunnel
dst..

Dengan demikian maka traffic outgoing maupun incoming dari local dan international terpisah sehingga dari eth1 ke router distribution 2.2.2.1 dapat di beri Mikrotik sebagai bridge utk melimit traffic international dan pada mikrotik router untuk melimit local traffic yang melalui tunnel.

Tulis sebuah Komentar

You must be logged in to post a comment.
%d blogger menyukai ini: