Memisahkan Bandwidth Lokal dan International menggunakan Mikrotik

Versi 3

Perubahan dari versi sebelumnya:

  1. Proses mangle berdasarkan address-list
  2. Pemisahan traffic Indonesia dan overseas lebih akurat

Semakin berkembangnya konten Internet lokal di Indonesia telah memberikan peluang bisnis baru dalam industri Internet di Indonesia. Saat ini banyak Internet Service Provider
(ISP) yang menawarkan paket bandwidth lokal atau IIX yang lebih besar dibandingkan bandwidth Internet Internasional, hal ini seiring dengan semakin banyaknya pengelola RT-RW Net yang mampu menyediakan layanan koneksi Internet yang lebih terjangkau bagi lingkungan sekitarnya.

 

Permasalahan umum yang terjadi pada jaringan RT-RW Net adalah masalah pengaturan bandwidth. Pada umumnya pengelola RT-RW Net akan kesulitan pada saat ingin memisahkan antara traffic lokal dengan traffic internasional karena umumnya jaringan RT-RW Net hanya menggunakan static routing, berbeda dengan ISP yang mampu membangun jaringan yang lebih komplek menggunakan protocol routing BGP sehingga ISP dapat dengan mudah memisahkan antara traffic local dan internasional.

 

Untuk memisahkan traffic lokal dengan traffic internasional tersebut RT-RW Net dapat dengan mudah menggunakan PC Router + Sistem Operasi Mikrotik, Mikrotik sebenarnya adalah linux yang sudah di buat sedemikian rupa oleh pengembangnya sehingga sangat mudah diinstall dan di konfigur dengan banyak sekali fitur dan fungsi. Untuk lebih lanjut mengenai mikrotik dapat dilihat pada situs webnya http://www.mikrotik.com atau http://www.mikrotik.co.id

 

Berikut adalah sekenario jaringan dengan Mikrotik sebagai router

Image

Gambar 1. Sekenario Jaringan

 

Penjelasan:

  1. Mikrotik Router dengan 2 Network Interface Card (NIC) Ether1 dan Ether3, dimana Ether1 adalah Ethernet yang terhubung langsung ke ISP dan Ether3 adalah Ethernet yang terhubung langsung dengan jaringan 192.168.2.0/24
  2. Bandwidth dari ISP misalnya 256Kbps internasional dan 1024Kbps lokal IIX
  3. Komputer 192.168.2.4 akan diberi alokasi bandwidth 128Kbps internasional dan 256Kbps lokal IIX

 

Untuk memisahkan antara traffic lokal IIX dengan traffic internasional caranya adalah dengan menandai paket data yang menuju atau berasal dari jaringan lokal IIX menggunakan mangle. Pertanyaannya bagaimana caranya Mikrotik bisa mengetahui paket tersebut menuju atau berasal dari jairngan lokal IIX?

Jawabannya adalah dengan mengambil data dari http://lg.mohonmaaf.com

karena http://lg.mohonmaaf.com sudah tidak aktif maka data dapat diambil dari:

http://203.89.24.3/cgi-bin/lg.cgi

Pilih Query dengan men-cek-list BGP dan klik Submit

Image

Gambar 2. Hasil Query http://lg.mohonmaaf.com untuk perintah “show ip bgp”

 

Fungsi dari http://lg.mohonmaaf.com adalah sebagai fasilitas looking glass jaringan lokal yang dikelola oleh PT. IDC , terima kasih kepada Bapak Johar Alam yang telah menyediakan layanan tersebut.

Dari hasil query tersebut selanjutnya simpan sebagai text files untuk selanjutnya dapat diolah dengan menggunakan spreadsheet contohnya Ms. Excel untuk mendapatkan semua alamat Network yang diadvertise oleh router-router BGP ISP lokal Indonesia pada BGP router IDC atau National Inter Connection Exchange (NICE).

Pada penjelasan versi-2 dokumen ini saya menggunakan teknik langsung memasukkan daftar ip blok ke /ip firewall mangle, dengan teknik ini saya harus memasukkan dua kali daftar ip yang didapat dari router NICE ke /ip firewall mangle.

Cara lain yang lebih baik adalah dengan memasukkan daftar ip blok dari router NICE ke /ip firewall address-list dengan demikian maka pada /ip firewall mangle hanya terdapat beberapa baris saja dan pemisahan traffic Indonesia dan overseas dapat lebih akurat karena mangle dapat dilakukan berdasarkan address-list saja.

Lebih jelasnya adalah sbb:

Selanjutnya buat script berikut untuk dapat diimport oleh router Mikrotik

/ ip firewall address-list
add list=nice address=58.65.240.0/23 comment=”” disabled=no
add list=nice address=58.65.242.0/23 comment=”” disabled=no
add list=nice address=58.65.244.0/23 comment=”” disabled=no
add list=nice address=58.65.246.0/23 comment=”” disabled=no
add list=nice address=58.145.174.0/24 comment=”” disabled=no
add list=nice address=58.147.184.0/24 comment=”” disabled=no
add list=nice address=58.147.185.0/24 comment=”” disabled=no
dst…

untuk mendapatkan script diatas dapat melalui URL berikut:

http://www.datautama.net.id/harijanto/mikrotik/datautama-nice.php

URL diatas secara online akan melakukan query ke router NICE dari http://lg.mohonmaaf.com

CATATAN:

Karena lg.mohonmaaf.com tidak dapat diakses maka utk daftar ip local dapat di ambil dari

http://ixp.mikrotik.co.id/download/nice.rsc

atau dari http://www.datautama.net.id/harijanto/mikrotik/datautama-nice.php

yang datanya dari looking glass DatautamaNet

 

dari hasil URL diatas copy lalu paste ke mikrotik dengan menggunakan aplikasi putty.exe ssh ke ipmikrotik tersebut, caranya setelah di copy teks hasil proses URL diatas lalu klik kanan mouse pada jendela ssh putty yang sedang meremote mikrotik tersebut. Cara ini agak kurang praktis tetapi karena jika script diatas dijadikan .rsc ternyata akan bermasalah karena ada beberapa baris ip blok yang saling overlap sebagai contoh:

\… add address=222.124.64.0/23 list=”nice”
[datautama@router-01-jkt] > /ip firewall address-list \
\… add address=222.124.64.0/21 list=”nice”
address ranges may not overlap

dimana 222.124.64.0/21 adalah supernet dari 222.124.64.0/23 artinya diantara dua blok ip tersebut saling overlap, sehingga pada saat proses import menggunakan file .rsc akan selalu berhenti pada saat menemui situasi seperti ini.

Sampai saat ini saya belum menemukan cara yang praktis utk mengatasi hal tersebut diatas.
Kalau saja kita bisa membuat address-list dari table prefix BGP yang dijalankan di mikrotik maka kita bisa mendapatkan address-list dengan lebih sempurna.

 

Selanjutnya pada /ip firewall mangle perlu dilakukan konfigurasi sbb:

/ ip firewall mangle
add chain=forward src-address-list=nice action=mark-connection \
new-connection-mark=mark-con-indonesia passthrough=yes comment=”mark all \
indonesia source connection traffic” disabled=no
add chain=forward dst-address-list=nice action=mark-connection \
new-connection-mark=mark-con-indonesia passthrough=yes comment=”mark all \
indonesia destination connection traffic” disabled=no
add chain=forward src-address-list=!nice action=mark-connection \
new-connection-mark=mark-con-overseas passthrough=yes comment=”mark all \
overseas source connection traffic” disabled=no
add chain=forward dst-address-list=!nice action=mark-connection \
new-connection-mark=mark-con-overseas passthrough=yes comment=”mark all \
overseas destination connection traffic” disabled=no
add chain=prerouting connection-mark=mark-con-indonesia action=mark-packet \
new-packet-mark=indonesia passthrough=yes comment=”mark all indonesia \
traffic” disabled=no
add chain=prerouting connection-mark=mark-con-overseas action=mark-packet \
new-packet-mark=overseas passthrough=yes comment=”mark all overseas \
traffic” disabled=no

Langkah selanjutnya adalah mengatur bandwidth melalui queue simple, untuk mengatur bandwidth internasional 128Kbps dan bandwidth lokal IIX 256Kbps pada komputer dengan IP 192.168.2.4 dapat dilakukan dengan contoh script sbb:

/ queue simple
add name=”harijant-indonesia” target-addresses=192.168.2.4/32 \
dst-address=0.0.0.0/0 interface=all parent=none packet-marks=indonesia \
direction=both priority=8 queue=default/default limit-at=0/0 \
max-limit=256000/256000 total-queue=default disabled=no
add name=”harijanto-overseas” target-addresses=192.168.2.4/32 \
dst-address=0.0.0.0/0 interface=all parent=none packet-marks=overseas \
direction=both priority=8 queue=default/default limit-at=0/0 \
max-limit=128000/128000 total-queue=default disabled=no

Script diatas berarti hanya komputer dengan IP 192.168.2.4 saja yang di batasi bandwidthnya 128Kbps internasional (overseas) dan 256Kbps lokal IIX (indonesia) sedangkan yang lainnya tidak dibatasi.

Hasil dari script tersebut adalah sbb:

Image

Gambar 3. simple queue untuk komputer 192.168.2.4

Dengan demikian maka komputer 192.168.2.4 hanya dapat mendownload atau mengupload sebesar 128Kbps untuk internasional dan 256Kbps untuk lokal IIX.

Untuk mengujinya dapat menggunakan bandwidthmeter sbb:

 

Image

Gambar 4. Hasil bandwidth meter komputer 192.168.2.4 ke lokal ISP

 

Image

Gambar 5. Hasil bandwidth meter ke ISP internasional

Dengan demikian berarti Mikrotik telah berhasil mengatur pemakaian bandwidth internasional dan lokal IIX sesuai dengan yang diharapkan pada komputer 192.168.2.4.

Pada penjelasan versi-3 ini proses mangle terhadap traffic “overseas” dapat lebih akurat karena menggunakan address-list dimana arti dari src-address=!nice adalah source address “bukan nice” dan dst-address=!nice adalah destination address “bukan nice”.

Sehingga demikian traffic “overseas” tidak akan salah identifikasi, sebelumnya pada penjelasan versi-2 traffic “overseas” bisa salah indentifikasi karena traffic “overseas” di definisikan sbb

add connection-mark=mark-con-indonesia action=mark-packet new-packet-mark=indonesia chain=prerouting comment=”mark indonesia”
add packet-mark=!indonesia action=mark-packet new-packet-mark=overseas chain=prerouting comment=”mark all overseas traffic”

packet-mark=!indonesia artinya “packet-mark=bukan paket Indonesia”, padahal “bukan paket Indonesia” bisa saja paket lainnya yang telah didefinisikan sebelumnya sehingga dapat menimbulkan salah identifikasi.

Adapun teknik diatas telah di test pada router mikrotik yang menjalankan NAT , jika router mikrotik tidak menjalankan NAT coba rubah chain=prerouting menjadi chain=forward.

Untuk lebih lanjut mengenai pengaturan bandwidth pada Mikrotik dapat dilihat pada manual mikrotik yang dapat didownload pada

http://www.mikrotik.com/docs/ros/2.9/RouterOS_Reference_Manual_v2.9.pdf

Script diatas dapat diimplementasikan pada Mikrotik Versi 2.9.27 , untuk versi mikrotik sebelumnya kemungkinan ada perbedaan perintah.

Reference:

* http://www.mikrotik.com
* http://www.mikrotik.co.id
* http://wiki.mikrotik.com

Selamat mencoba.

14 Comments

  1. ratnoz
    Posted Juni 8, 2007 at 9:03 pm | Permalink

    makasih banget mas
    artikelnya bagus banget coz aku mau belajar mikrotik lebih dalem

    klo ada updatena kirim donk mas ke email aku ratnoz@telkom.net

    thankz..
    🙂

  2. tape_uwie
    Posted Juni 19, 2007 at 2:46 am | Permalink

    makasih atas infonya, tapi
    http://www.mikrotik.com/docs/ros/2.9/RouterOS_Reference_Manual_v2.9.pdf
    koq ga bisa di download,
    tolong kirim ke wartel_crew@yahoo.co.id

    tolong yah…

  3. indra
    Posted Juni 25, 2007 at 9:00 am | Permalink

    bagi kawan2 yang punya panduan mengenai software mikrotik 1 by 1 dan step by step langkah penggunaan daripada software mikrotik mohon email ke gwa ya penting banget nich soalnya wa lagi mo mendalami mikrotik

  4. Posted Juni 26, 2007 at 1:17 am | Permalink

    wah ini kan dari webnya ISP datautama.net.id yg ada di semarang???

  5. Nindita
    Posted Juli 9, 2007 at 12:52 pm | Permalink

    bro klo kita punya 2 langganan misal vsat dan speedy, trus caranya biar iixnya cuman lewat speedy, internasional lewat vsat gmn?

  6. hendri
    Posted Agustus 6, 2007 at 5:17 am | Permalink

    mas yg disebut mikrotik itu apa?……
    apa itu program atau bukan….

  7. uwiuw
    Posted September 19, 2007 at 9:06 am | Permalink

    makasih…artikel ini membantu sy untuk memahai beberapa lekuk-lekuk internet

    danke!

  8. bayu
    Posted September 28, 2007 at 4:32 pm | Permalink

    mas aku mau tanya gimana cara mengontrol bandwith saya dan mengatur wireless saya agar tidak dibobol..?and saya masih bingung bagaimana caranya memberikan bandwith ke client beda-beda,ama mikrotik untuk local dan international?

    please help me,sebab gue kebingungan banget,cuap2x wala thanks

  9. sastra
    Posted Oktober 23, 2007 at 7:24 am | Permalink

    mas mo tanya neh, gimana cara membagi jaringan untuk gameonline dan browsing dalam satu warnet yg mengguna media vsat sebagai media netnya, krn klo bersamaan selalu ngelag neh,..plz dong bantuannya..thank’s wassalam

  10. Posted Desember 27, 2007 at 8:32 am | Permalink

    Ane udah coba tapi kok masih gak ada trafficnya nape yah bosss ??? plz give me solution dech😀

  11. Posted Februari 29, 2008 at 2:48 pm | Permalink

    tolong kirimkan saya langkah-langkah tentang cara membagi bandwicth, soalnya saya ada masalah tentang pembuatan tugas akhir sekolah.

  12. zaenal
    Posted Mei 26, 2008 at 9:04 pm | Permalink

    kalo bandwitdh speedy kira2 bisa dipisahkan ga yach intel dan iix na ??? mohon pencerahan nya

  13. Yan Rudianto
    Posted Agustus 19, 2008 at 12:45 pm | Permalink

    Thank’s atas informasinya !!!

  14. orng_mw_belajar
    Posted Oktober 24, 2010 at 8:10 am | Permalink

    ia ni mas,, knp yg overseasnya aja y yg bs k tangkep,, trafic dr indonesia g dpt sm sekali..
    bingung ni mas,,


One Trackback/Pingback

  1. […] tinggalkan komentar » untuk memisahkan kita bisa lihat di web link berikut […]

Tulis sebuah Komentar

You must be logged in to post a comment.
%d blogger menyukai ini: